You are logged in as a guest. ( Logon | Register Now! )



Anyone ever seen this?
Jump to page : 1
Now viewing page 1
   Fishing Boats, Motors, Trailering, Q & A or Discussion

Posted by FishinChef
6/2/2019 10:46 AM
I'm running a new Mercury pro xs and probably have 10 hours at most on the motor. I noticed this the other day coming from the exhaust relief port. Not sure if it's leftover from part manufacturing or something way more serious. It seems to be plastic/resin. Motor has been running just fine. Let me know
Posted by FishingwithRusty
6/3/2019 9:16 AM
if you havent already id call the dealer you bought it from and talk to them, something doesnt sound right
Posted by FishinChef
6/3/2019 9:21 AM
Yeah, I'm waiting on the service manager to call back to set up a date and time. Sorry, I was trying to get my pictures to upload but couldn't get it going. Really bummed about it, I have the summer off and this wasn't how I planned to spend it lol. But not sure what's going on with it, I never lost water pressure or anything noticeable from the engine. It's Got me scratching my head.
Posted by ficht158
6/3/2019 12:35 PM
might check on the merc forum on bass boat central.
Spread the word

del.icio.us Digg Furl Reddit BB Google Ma.gnolia Netscape Simpy StumbleUpon Technorati Live Yahoo!

Jump to page : 1
Now viewing page 1
Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread
 

Advertiser

Advertiser

CFF Calendar
July 2019
SMTWTFS
  1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21» 22 23 24 25 26 27
28 29 30 31      

Upcoming events (next 2 weeks)
Jul 21 Dream Chasers Tournament #5 CFP

Advertiser

Random Photo


Album: peck's


(Delete all cookies set by this site)

Copyright © 1996-2019 All rights reserved.
Duplication in whole or in part of this Web site without express written consent is prohibited.
CFF Privacy Policy

Running MegaBBS ASP Forum Software
© 2002-2019 PD9 Software